CONFIG_HW_CC310_INTERRUPT

Use interrupt version of nrf cc310 platform library

Use interrupt version of nrf cc310 platform and crypto libraries

Type: bool

Direct dependencies

NRF_CC310_BL || NRF_CC310_PLATFORM || (CC310_BACKEND && NORDIC_SECURITY_BACKEND)

(Includes any dependencies from ifs and menus.)

Default

  • n

Kconfig definitions

At /jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/crypto/Kconfig:21

Included via Kconfig:8Kconfig.zephyr:9/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/test_doc/_build/Kconfig.modules:5/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/Kconfig.nrfxlib:13

Menu path: (Top) → Modules → Nordic nrfxlib → Crypto libraries for nRF5x SOCs. → nrf_cc310_bl HW crypto library for nRF devices with CryptoCell CC310.

config HW_CC310_INTERRUPT
    bool
    default n
    depends on NRF_CC310_BL

At /jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/crypto/Kconfig:34

Included via Kconfig:8Kconfig.zephyr:9/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/test_doc/_build/Kconfig.modules:5/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/Kconfig.nrfxlib:13

Menu path: (Top) → Modules → Nordic nrfxlib → Crypto libraries for nRF5x SOCs. → nrf_cc310_platform HW crypto library for nRF devices with CryptoCell CC310.

config HW_CC310_INTERRUPT
    bool "Use interrupt version of nrf cc310 platform library" if !(CC310_BACKEND || NRF_CC310_BL)
    depends on NRF_CC310_PLATFORM

At /jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/nrf_security/Kconfig:91

Included via Kconfig:8Kconfig.zephyr:9/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/test_doc/_build/Kconfig.modules:5/jenkins_workspace/workspace/nrfconnect-nrf_doc_v1.2-branch_2/nrfxlib/Kconfig.nrfxlib:14

Menu path: (Top) → Modules → Nordic nrfxlib → Nordic Security → Use Nordic provided security backend → Use cc310 backend

config HW_CC310_INTERRUPT
    bool "Use interrupt version of nrf cc310 platform and crypto libraries"
    depends on CC310_BACKEND && NORDIC_SECURITY_BACKEND

(The ‘depends on’ condition includes propagated dependencies from ifs and menus.)