CONFIG_BT_SPI_BLUENRG

Enable compatibility with BlueNRG-based devices

Type: bool

Help

Enable support for devices compatible with the BlueNRG Bluetooth Stack. Current driver supports: ST BLUENRG-MS.

Direct dependencies

(BT && BOARD_DISCO_L475_IOT1) || (BT_SPI && BT_HCI && BT && !BT_CTLR)

(Includes any dependencies from if’s and menus.)

Defaults

Kconfig definitions

At boards/arm/disco_l475_iot1/Kconfig.defconfig:143

Included via Kconfig:10Kconfig.zephyr:21

Menu path: (top menu)

config BT_SPI_BLUENRG
    bool
    default "y" if BT && BOARD_DISCO_L475_IOT1
    depends on BT && BOARD_DISCO_L475_IOT1

At drivers/bluetooth/hci/Kconfig:82

Included via Kconfig:10Kconfig.zephyr:35drivers/Kconfig:12drivers/bluetooth/Kconfig:20

Menu path: (top menu) → Device Drivers → Bluetooth Drivers

config BT_SPI_BLUENRG
    bool
    prompt "Enable compatibility with BlueNRG-based devices" if BT_SPI && BT_HCI && BT && !BT_CTLR
    depends on BT_SPI && BT_HCI && BT && !BT_CTLR
    help
      Enable support for devices compatible with the BlueNRG Bluetooth
      Stack. Current driver supports: ST BLUENRG-MS.

(Definitions include propagated dependencies, including from if’s and menus.)